Hnet Info Download

Přehled aplikace
Používáme Hnet Info Download
Jak pracuje Hnet Info Download

Technické údaje

  • Verze: 1.1
  • Rok: 2001
  • Velikost spustitelné aplikace: cca 2MB

Poznámka

Windows(r) je definovaná ochranná známka firmy Microsoft.


Vítejte v Hnet Info Download nápovědě!

Hnet Info Download je určen pro offline prohlížení stránek, zrcadlení website a stahování souborů z Internetu. Hnet Info Download je plně automatický nástroj, který stahuje všechny soubory odkudkoliv z Internetu. Umí kompletně stáhnout website tak, že Vám umožní offline prohlížení, které bude mnohem rychlejší než, když stránky stahujete přímo ze sítě. Vytvoří přesnou kopii nebo mirror website se stejnou strukturou adresářů a všemi požadovanými soubory. Prohledává odkazy podle přítomnosti zadaných klíčových slov a stahuje pouze soubory požadovaného typu.

Hnet Info Download je užitečný pomocník, který ukončí dlouhé čekání na natažení stránky, automaticky vytváří kopie website a stahuje soubory podle naplánovaného scénáře.

Používáme Hnet Info Download

 Přehled tutorialu


Používáme Hnet Info Download

Při používání Hnet Info Downloadu vytváříte projekty, které obsahují jednu nebo více počátečních adres pro stahování souborů z Internetu.

Dále specifikujete omezení odkazů, které se mají sledovat a můžete poslat robota na cestu Internetem výběrem příkazu Start z menu Soubor nebo stisknutím tlačítka Start na tlačítkové liště.

Poté robot přečte počáteční adresu, kterou jste mu zadali a stáhne soubory, které na ní najde. Dále zjistí všechny odkazy na této stránce a pokud vyhovují podmínkám, které jste zadali, tak stahuje všechny soubory na těchto nových adresách a znova opakuje postup, dokud nestáhne vše, co se dá.

Hnet Info Download může stahovat pouze určité typy souborů, které mu zadáte např. jenom text nebo také grafiku a zvuk. Dále je možné omezit následování odkazů pouze na ty, které obsahují nebo naopak nesmí obsahovat specifické klíčové slovo nebo přikážete robotovi, aby neopustil doménu, na které začal skenovat, nepouštěl se dále než do specifikované úrovně počtu odkazů.

Hnet Info Download umožňuje jednoduché nastavení projektu při použití Pomocníka pro nový projekt, který obsahuje šablony pro nejčastěji používané úlohy.

Jak Hnet Info Download pracuje

 Přehled tutorialu


Jak Hnet Info Download pracuje.

Hnet Info Download analyzuje každou staženou stránku a hledá na ní všechny odkazy na další stránky a na soubory. Poté tyto odkazy třídí podle zadaných parametrů a stahuje všechny soubory, které těmto parametrům vyhovují. Každý stažený soubor je uložen v projektovém adresáři pojmenovaném podle jména projektu.

U odkazů na další stránky Hnet Info Download zkontroluje, jestli nepřesahují zadaný limit pro počet odkazů z počáteční stránky (tzv. hloubku prohledávání) a zda vyhovuje zadaným klíčovým slovům a pokud ano, stáhne ji a zpracuje stejným způsobem.
Pokud projekt obsahuje více počátečních adres, Hnet Info Download zopakuje postup pro každou z nich.

Jak Hnet Info Download postupuje při prohledávání, přidává nalezené stránky do stromové struktury projektu, která je zobrazena v levém okně aplikace (dále projektová mapa).
Kliknutím na libovolnou stránku v projektové mapě ji označíte a v pravém okně (seznam souborů) uvidíte soubory, které obsahuje.

Přehled tutorialu


Přehled tutorialu
 Nový projekt
Uložení projektu
Spuštění projektu
Prohlížení výsledků

Technické údaje

  • Verze: 1.1
  • Rok: 2001
  • Velikost spustitelné aplikace: cca 2MB

Poznámka

Windows(r) je definovaná ochranná známka firmy Microsoft.


Přehled tutorial

V tomto tutorialu Vás naučíme základy používání Hnet Info Downloadu.
Existují 4 základní kroky pro vytvoření a spuštění projektu.

  1. Vytvoření nového projektu
  2. Uložení projektu
  3. Spuštění projektu
  4. Prohlížení výsledků


Nový projekt

Pro vytvoření nového projektu zvolte příkaz Pomocník po nový projekt ebo stiskněte tlačítko Pomocník pro nový projekt na tlačítkové liště. (Pokročilí uživatelé mohou také začínat tlačítkem Nový projekt, ale budou muset nastavit Vlastnosti projektu ručně). Pomocník pro nový projekt se Vás zeptá na několik otázek pro zjištění Vašich požadavků a vytvoří podle nich nový projekt.

Strana 1: Zde jsou tři šablony pro nejvíce používané úkoly.

Pro tento tutorial zvolte " Vytvořit kopii na mém pevném disku"

Strana 2: Pomocník se Vás pak zeptá na počáteční adresu. To je místo, odkud Hnet info Download začne prozkoumávat stránky až do hloubky, kterou zadáte do políčka pod počáteční adresou.

Pro tento tutorial zvolte: www.hnetinfo.com

Strana 3: Zde si vyberete, co všechno chcete stahovat a také zde můžete zadat doplňjící údaje pro tento projekt.

Pro tento tutorial zvolte "všechno"

Strana 4: Musíte stisknout tlačítko "dokončit" a následně budete vyzváni k zadání jména projektu na disku.

Uložení projektu


Uložení projektu

Pokud používáte Pomocníka, tak se Vám nyní zobrazil dialog Uložit jako. Pokud Pomocníka nepoužíváte, musíte zvolit položku Uložit projekt jako z menu Soubor. Hnet Info Download pak zobrazí dialog Uložit jako.
Zadejte jméno Vašeho projektu do políčka Název souboru. Můžete přitom změnit aktuální adresář tak, aby jste měli projekt uložen tam, kde si přejete.

Pro tento tutorial napište jméno Hnetinfo a stikněte tlačítko Uložit.

Poznámka: Hnet Info Download vytvoří podadresář pojmenovaný podle Vašeho projektu, ve kterém se uloží všechny stažené soubory.

Spuštění projektu


Spuštění projektu

Pro spuštění projektu zvolte Start z menu Projekt nebo stiskněte tlačítko Start na tlačítkové liště.
Hnet Info Download se připojí na počáteční adresu a začne stahovat soubory. Podrobnosti o způsobu práce Hnet Info Downloadu najdete zde.

Jak robot pracuje, zobrazuje se statistika na stavovém řádku. Nyní můžete nechat program pracovat na pozadí a počkat si na výsledky.

Po dokončení stahování, ale i během něho si můžete Prohlížet výsledky


Prohlížení výsledků

Levý panel obsahuje Projektovou mapu. Zde se zobrazuje hierarchie prozkoumaných stránek. Pro každou z nich se v pravém panelu zobrazí soubory, které daná stránka obsahuje. Soubory si můžete prohlížet jako seznam nebo i s podrobnými údaji. Použijte příkazy z menu Zobrazit pro přepínání mezi režimy zobrazení.

Stažené soubory jsou uloženy v projektovém adresáři, který byl vytvořen při prvním spuštění projektu a je pojmenován stejně jako projekt. Tento adresář je obvykle uložen na stejném místě jako projektový soubor.

Pro soubory v pravém panelu i pro stránky v levém jsou k dispozici menu, která se zobrazí po stisku pravého tlačítka myši. Zde máte možnost otevřít stažený soubor, přejmenovat jej, znovu stáhnout a podobně.

A to nejlepší na konec. Nyní můžete prohlížet stažené stránky offline, přímo ze svého disku, což, jak sami zjistíte, je mnohem rychlejší. Stránky můžete začít prohlížet přímo z Hnet Info Downloadu, klikněte pravým tlačítkem myši na některou stránku v Projektové mapě a zvolte Otevřít.

Tento tutorial je u konce. Nyní máte dostatek znalostí pro vytváření a spouštění vlastních projektů. Popis pokročilých nastavení projektu najdete zde.


Vlastnosti projektu - Stránka Souhrn
 Vlastnosti projektu - Stránka Stahování souborů/Zkoumání
 Vlastnosti projektu - Stránka Prohlížení/Zrcadlení
 Vlastnosti projektu - Stránka Omezení
 Vlastnosti projektu - Stránka Rozšíření/Netiquette


Vlastnosti projektu - stránka Souhrn

Stránka souhrn Vám nabízí souhrnné informace o Vašem projektu:kdy byl projekt naposledy spuštěn, kolik bylo staženo souborů a načteno stránek, kolik projekt obsahuje počátečních adres, celkový počet stažených bajtů a velikost databáze projektu.

Dále je zde možné smazat projektovou databázi. Při mazání jste dotázáni, zda si přejete smazat také všechny stažené soubory na disku. Používejte toto tlačítko opatrně, projekt se nastaví do počátečního stavu a ztratíte veškeré stažené soubory a informace o jejich návaznostech.


Vlastnosti projektu - stránka Stahování souborů/Zkoumání

Stahovací módy
Zde nastavte jednu z možností, která vyhovuje nejvíce Vašim požadavkům na stahovaná data.
"Stahovat pouze text" je nejrychlejší varianta, pokud Vás zajímá pouze textový obsah stránek.
"Stahovat text a grafiku" stahuje oproti přechozímu také grafiku, takže na stažených stránkách uvidíte také obrázky.
"Stahovat text, grafiku a zvuk" tuto variantu použijte např. pro stahování mp3 souborů.
"Stahovat všechny soubory" stáhnou se všechny nalezené soubory bez ohledu na jejich typ.

Vlákna
Zde se nastavují počty souběžných vláken, které Hnet Info Download použije při své práci. Pokud nerozumíte procesům operačního systému, doporučujeme ponechat původně nastavené hodnoty (3 pro skenování a 7 pro stahování).

Poslední volba na této stránce se týká dodržování Robot Exclusion Standardu, což při aktivaci omezí práci Hnet Info Downloadu pouze na ty části serveru, které jeho správce označil jako přístupné, jinak bude robot stahovat všechna data, na která narazí.


Vlastnosti projektu - stránka Prohlížení/Zrcadlení

"Napodobit adresářovou strukturu vzdáleného serveru"
Použijte tuto volbu, pokud chcete mít úplnou kopii serveru. Hnet Info Download vytvoří na Vašem disku stejnou strukturu adresářů, jaká je na vzdáleném serveru.

"Vytvořit mapu serveru"
Při použití této volby se nebudou ukládat na disk žádné soubory. Hnet Info download pouze zmapuje server a předloží Vám seznam souborů, které jsou na serveru uloženy.

"Systém přelinkování"
Přelinkování je důležitý proces pro offline prohlížení,při kterém se procházejí všechny stažené stránky a presměrují se v nich odkazy na soubory na Vašem disku, takže doporučujeme ponechat volbu "Lokalizovat odkazy" zapnutou.
Dále je možno zvolit, jak se Hnet Info Download zachová, pokud při přelinkování narazí na odkaz na soubor, který nebyl stažen. Je možno zvolit mezi ponecháním původní adresy a přesměrováním na vysvětlující zprávy. Přesměrování je ovšem časově náročnější a tak doporučujeme ponechat odkaz na originální soubor.

Tlačítko "Přelinkovat všechny soubory projektu" slouží k okamžitému provedení přesměrování, ale za normálních okolností není zapotřebí jej používat, protože projekt se přelinkuje automaticky při dokončení stahování.


Vlastnosti projektu - stránka Omezení

Hnet Info Download umožňuje omezit stahované soubory podle výskytu klíčových slov. Jsou dvě možnosti omezení:
1. Adresa stránky nesmí obsahovat zadaná klíčová slova.
Tuto kontrolu zapnete zaškrtnutím volby "Povolit" nad polem do kterého zadáte příslušná klíčová slova.

2. Adresa stránky musí obsahovat zadaná klíčová slova.
Tuto kontrolu zapnete zaškrtnutím volby "Povolit" nad polem do kterého zadáte příslušná klíčová slova.

"Html přípony"
Do tohoto políčka můžete zadat přípony souborů, které mají být analyzovány jako html stránky. Smazáním původního nastavení můžete znemožnit funkci Hnet Info Download, v tom případě použijte tlačítko "Původní" pro obnovení výchozího nastavení.


Vlastnosti projektu - stránka Rozšíření/Nettiquete

Automatizace projektu
Zde si můžete zvolit, zda se má projekt spustit ihned po otevření, určit maximální dobu běhu projektu, popřípadě nastavit opakované spouštění projektu po uplynutí stanovené doby a nakonec také ukončení činnosti Hnet Info Downloadu po dokončení projektu.

Identita
Nastavte identifikaci robota, který bude prohledávat www stránky.